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More help is available From the PCB Artist Tips & Tools Page and via email 

at layouthelp@4pcb.com
 
This page is not intended to replace the Tutorial in PCB Artist, which is found from 
the main menu of PCB Artist under Help>Tutorials>Design Tutorial.  The purpose 
of this document is to provide an overall process flow with guidance for the various 
steps in the process of designing a printed circuit board in PCB Artist.  More specific 
questions can be answered in the Frequently Asked Questions document and also in 
the main menu of PCB Artist under Help>Contents. 
 
It is recommended to read each section of this guide as one moves through the 
successive phases of the design process.  It is not necessary to read further in the 
document than you have progressed in your design.  
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Beginning a Design: 
 Determine if the design will be done using a schematic or if the design will be 

PCB-only (meaning that no schematic will be created).  Here are some points 
to consider in making that decision: 

o If a design is going to have a schematic, it must be done first.  The 
system is not designed to reverse engineer the completed PCB design 
back to schematic.  Only reference designation can be back annotated 
from the PCB design to the schematic. 

o All electrical changes to be made to a design should be made in the 
schematic and then forwarded to the PCB to keep them synchronized.  
This is done from the main menu, under 
Tools>Schematic >PCB>Forward Design Changes. 
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o The link between the schematic file and the PCB file is that they both 
have the same filename (the same other than the .sch and .pcb 
extension) and that they are in the same directory. 

o If the design will have no schematic, then any component parts that 
have to be created can be PCB-only components.  This can speed the 
process of making components by eliminating the steps of making or 
finding a Schematic Symbol and also eliminates the need for mapping 
pins and assigning logic names. 

o One advantage of creating a schematic and then a PCB is to 
concentrate first on the purely electrical and then concentrate purely 
on the physical aspects of the design.  PCB only designs do have a tool 
that can imitate that separation of design aspects.  From the main 
menu, use Add>Connection to create connections from pin to pin to 
establish electrical connectivity without needing to worry about tracks, 
spaces, layers, etc.  The auto router can then use those connections to 
rout the board on a PCB only design.  The auto router needs those 
connections at the minimum to function. 

 

 
 

 Put together a Bill of Materials and determine which parts are in the library or 
in the online library.  Create any parts not in the library.  See the Component 
Library section, below, for details. 



 When starting a design, go to Settings>Units and change the units as 
necessary.  One important setting that should not be overlooked is the 
Precision.  The Precision setting controls how many decimal places are 
allowed to be displayed or entered.  When working in inches use Precision 4, 
in mils use Precision 1, and with millimeters the Precision should be set to 3.  

 

 
  

 It is important in either PCB or schematic to set the proper working grid.  
Grids are set from the main menu of PCB Artist under Settings>Grids.  Always 
begin with large grids for beginning projects and then make the grids smaller 
for fine tuning.   

 

 
 

 Setting the System Origin in the PCB. 
o It is not a good practice to create the design in the lowest left extreme 

of the design work area to use the default coordinate origin.  If an 
item’s width crosses outside the work area, the application will move it 
back into the work area and cause many serious issues. 

o The system origin, grid origin, and all displayed coordinates can be 
changed by the user at any time by setting the System Origin.   

o It is a good practice after a PCB is first created to select the lower left 
corner of the board (the bright green board outline), right-click and 
choose Origins>Set System Origin At Item.  This will snap the origin of 
all coordinates and the grid to an end point of the selected segment.  

 



 
  

o The System Origin can snap to any item, such as mounting holes. 
o A thin, white colored target (in the PCB editor) will appear where the 

system origin now resides.  
 

 
  

o Be aware that changing origins must be done with care, so as not to 
lose the origin point from which objects were placed.  It is not a good 
practice to change the system origin after tracks have been routed as 
the grid also uses the system origin. 

 

General Navigation: 
 

 The higher processes and tools are available from the main menu and many 
are available in the icon bars and from shortcut keys (hotkeys).  Many item-
specific tools are available from the context menus (right-click menus) when 
an item is selected. 

 All Icon Bars can be hidden and recalled by a right-click over an empty space 
in the gray background at the very top of the application.  A menu will display 
with check marks indicating which menu bars are displayed and which are 
not.  Selecting a menu choice will toggle it on or off. 

 



 
 

 The Interaction Bar serves as a way to quickly access frequently used options.  
It can be brought up or hidden with the <F9> shortcut key.   

 

 
 

o In a PCB design, one key function of the Interaction Bar is the Layers 
tab in the lower left of the bar.  This can be used to control which 
layers are currently displayed.   

 

 
 

o The Interaction Bar is also the most efficient way to add Components 
to a design in either a PCB or Schematic as mentioned below in the 



Schematics section.  The Add Component tab of the Interaction Bar is 
in the lower right of the bar. 

 

 
 

 
 

o The Goto tab of the Interaction Bar is a feature for finding various 
items in the design such as Nets, Design Rule Check Errors, and 
specific components.  Items found are automatically selected and a 
double click on a listed item will select every instance of the selected 
item type (depending on what type of item is being searched).  A 
right-click over an list in the Goto tab will display many options for 
selection and highlighting. 

 



 
 

 
 

 The Status Bar is in the lower right frame of the application and displays 
current settings such as the units setting, the current coordinates of the 
cursor, etc.  When an item is selected (such as a pad), a list of information 
about that item is displayed in the Status Bar, such as the pad style, the net 
of the pad, the layer it exists on.   

 

 
 

 The easiest graphical navigation is with a wheel mouse.  Not only for its zoom 
capabilities, but because it can be used most effectively to pan through the 
design.  A single click on the wheel of the mouse (as though it were a mouse 
button) will re-center the screen to where the cursor was located.  Clicking 
and holding the wheel button down while moving the mouse will allow 
dynamic panning through the image.  Dynamic panning with the wheel mouse 
can also be done while adding features to the schematic or PCB Design.  The 



characteristics of dynamic panning can be customized from the main menu of 
PCB Artist under Settings>Preferences in the Autopan section of that dialog. 

 Many right-click shortcut menus are available with options that change 
depending on the context of your situation.  Many options exist only in very 
specific conditions.  For example, when a track is selected, the right-click 
context menu will display track-related options and will not show options that 
would be available specifically to pads. 

 

 
 

 If you are trying to select one specific object from among many at the same 
location, click over the object and press the <N> button (the hotkey for 
cycling through objects) and the application will cycle through each object at 
the location where the mouse was clicked. 

 After making a change, it is sometimes necessary to refresh the screen to see 
the effect.  The hotkey for refresh is <V>. 

 Displaying nets for reference 
o When in Schematics, wire connections can be given a color from 

Settings>Nets.   
o Nets can be highlighted in both schematic and PCB from 

View>Highlight Net>Browse. 
o In the Interaction Bar (which is brought up with <F9>), click on the 

Goto tab at the bottom of that bar and change the top drop down to 
Net.  Clicking on one of the listed net names will select the net and 



cause it to flash.  If you right-click over the list of names, you are 
given options that including the ability to only highlight the net and not 
select it. 

 

Libraries: 
 

 All Library parts that come with PCB Artist or from the online library are for 
example only.  All Components used from either of the libraries must be 
verified by the designer before use. 

 The best location to search for library parts is in the Library Manager.   
o The Library manager is available from File>Libraries in the main menu 

and also from the blue book icon in the top icon bar.   
 

 
 

o The Online Library can be accessed from the Library Manager by 
pressing the Download Online Library Components button.  It is 
recommended to use the manufacturer part number primarily for 
searching the online library.  

 

 
 

o The Library Manager has four tabs in the upper left.  These are for 
searching the Schematic Symbols libraries, the PCB Symbols libraries, 
and the Component libraries.  The fourth tab is for managing folders of 
libraries.   

 



 
 

o It is not necessary to spend more than a few minutes searching for 
any part in the libraries.  Most parts can be created in a few minutes 
and that process is really quite simple.  

 When creating symbols and components, first use the Part Creation Tutorial 
to become familiar with the process.  Help specific to the Online Library is 
available from the PCB Artist Online Library Help Guide.  There are also 
guides available on the PCB Artist Tips & Tools page in the Frequently Asked 
Questions Document.  On the FAQ Document there are guides to the wizards 
for each of the symbol types as well as detailed instructions for manually 
creating parts that are not possible to create with wizards (such as switches 
and many types of connectors).  There are links to these guides in the first 
section of the hyperlinked index of the FAQ. 

 Only Components can be added to any design.  Components are made of a 
Schematic Symbol and PCB Symbol and in certain cases can be made of a 
PCB or Schematic only symbol.  If you create a PCB symbol, it must be added 
to a Component for it to be available to add to a design. 

 The reason the PCB and Schematic Symbols are stored separately is to allow 
the re-use of a symbol that already exists.  For example, a resistor symbol 
already exists, but a new PCB Symbol is needed.  In such cases the PCB 
Symbol would be created and then the existing Schematic symbol would be 
used in creating the Component. 

 Part creation is much easier than it is with other tools and methods of the 
past.  The PCB Symbol wizard is intended for creating parts with only the part 
datasheet containing a diagram of the part itself (as opposed to a diagram of 
the footprint, which is usually not provided from the part vendor).  The 
average PCB Symbol takes only about 1 minute to create in the wizard. 
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 Component Values 
o After creating the component, you can edit the part values to include 

the Manufacturer, Manufacturer Part Number, Distributor, and 
Distributor Part Number.  This can be done in the Library Manager.   

o Click on the Components tab at the top of the Library Manager.  
Change your library to the one containing the part or parts you wish to 
edit.  Then click on the Values button at the bottom of the middle row 
of buttons.  These values will be retained for every design using the 
part. 

 



 
 

o Component values can also be changed in the schematic or the PCB 
design, but the values assigned are retained for that design only 

 Warning:  Always create a new library of each symbol type (Schematic 
Symbols, PCB Symbols, and Components) to store your created or modified 
Components and symbols.  If it is ever necessary to reinstall the application 
the exiting libraries will be overwritten and anything in them will be lost.  A 
library created by the user would not be overwritten. 

 
 

More help is available From the PCB Artist Tips & Tools Page and via email 
at layouthelp@4pcb.com
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